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1 前言 

1.1 版本参照 

此说明是参照流光 5测试版 2（Fluxay5 Beta2）的英文版编写，对于版

本语言不同和将来的更新而造成和此说明不一致的地方，恕不另行通知。 

1.2 设计目标 

流光 5 并不是单纯的漏洞弱点扫描工具，而是一个功能强大的渗透测试工

具。凭借流光的高度综合性和灵活性，流光在渗透测试(Penetration Test)

方面表现出了独特的优势。 

1.3 漏洞扫描 

流光的漏洞扫描也是众多扫描其中最具特色的一个，除了提供全面的扫描功

能以外，利用 C/S结构设计的扫描思想更是在众多复杂的应用场合脱颖而出。 

流光目前的漏洞扫描包括: 

POP3、FTP、IMAP、TELNET、MSSQL、MYSQL、WEB、IPC、RPC、DAEMON

等。 

1.3.1 暴力破解 

提供POP3/FTP/IMAP/HTTP/PROXY/MSSQL/SMB/WMI的暴力破解功能。 
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1.3.2 网络嗅探 

利用 ARP 欺骗，对交换环境下的局域网内主机进行嗅探。和流光的漏洞扫

描模块一样，网络嗅探也采用了 C/S的结构，可以提供远程网络的嗅探功能。 

1.3.3 渗透工具 

包括 SQLCMD/NTCMD/SRV/TCP Relay等得心应手的辅助渗透工具。 

1.3.4 字典工具 

可以定制各种各样的字典文件，为暴力破解提供高效可用的字典。 

1.3.5 杂项工具 

PcAnyWhere密码文件的解码等。 

1.4 申明 

请将本软件用于正确目的，其中的某些工具对网络可能会有危害；由于软件

的缺陷或者使用不当而引起的系统或者网络崩溃等后果，作者不负任何责任。如

果由此带来的一切法律后果由使用者自负。 

某些反病毒软件，会将流光的某些组件认为病毒，但实际情况并非如此。流

光的所有组件都不具有病毒的特质。 

1.5 限制 

流光 5中含有 IP地址数据库，禁止对国内 IP进行扫描，这麽做的原因有

两个：为了使用者也为了作者。 

流光 5的使用期限截止为 2003年 12月 31日。 
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流光 5是一个全免费的软件，任何人都可以自由传播。 

禁止对流光 5进行反向工程。 
禁止将流光 5用于商业目的。 

1.6 联系方式 

WEB: www.netXeyes.com  www.netXeyes.org 

E-Mail:xxxxx@vip.sina.com; security@vip.sina.com 

2 安装 

2.1 运行需要的基本环境 

流光 5（非特定版本）必须运行于 Windows 2000或者 Windows NT系统

中，内存不小于 128M。 

某些功能需要网络适配器（必须）。 

2.2 安装 

双击 Fluxay5Setup图标，按照提示进行，即可进行安装。 

3 开始之前 

3.1 注册组件 

在 流 光 的 安 装 目 录 下 ( 默 认 为 C:\Program 

Files\NetXeyes\Fluxay5Beta1\)，有一个目录 OCX,在此目录中有一个文

件 register.bat，这个文件是用于注册组件的，以保证流光中的某些组件功
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能能够正常使用。 

执行成功以后，会出现如下提示： 

 

3.2 设置密钥 

流光中的漏洞扫描采用了 C/S结构，其间通过 TCP进行通讯，通讯的数据

通过 3DES进行加密，所以在使用前需要设置一个密钥。 

在正常情况下，当第一次使用流光的时候，系统会自动提示输入密钥。 

 

密钥的设定规则为任意字母加数字，密钥设定后如需更改，可以通过菜单

[Tools]->Set Encyption Key来进行修改。 

3.3 安装本地扫描引擎 

＊此功能可选。 
如果需要在本地安装，需要在本地启动 Server服务。 

[Tools]->Fluxay Sensor Tools->Install Fluxay Sensor 
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Host IP： 本地网络适配器的 IP地址 

NT Account： 系统用户名，必须属于 Administrators 

NT Password：系统用户的密码 

Service Name：安装的服务名称 

Display Name： 服务的说明 

Description：服务的描述 

Control Process：控制服务的进程名 

Sensor Process：引擎的进程名 

Remark：注释 

Console Username： 控制服务的用户名，可以任意指定 

Console Password：控制服务的密码，可以任意指定 

Console Port： 控制服务监听的端口，可以任意指定 
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Sensor Port： 扫描引擎监听的端口，可以任意指定 

Disable Service Response for STOP： 服务将不会响应 STOP 命

令，成为系统的关键服务 

Force Overwirte： 如果文件已经存在，强性覆盖。 

☺ 在本地安装扫描引擎并不是必需的，除非本地的扫描引擎需要为远程的

流光提供扫描服务。 

3.4 安装本地嗅探引擎（需要网络适配器） 

＊ 此功能可选。 
如果需要在本地安装，需要在本地启动 Server服务。 

[Tools]->Remote Sniffer->Install ARP Network Sniffer 

 

 

IP Address：本地的 IP地址 

Account：系统的用户名，必须属于 Administrators组 

Password：系统的密码 

Listen Port: 嗅探引擎监听的端口 

ANS Passwd: 设定连接嗅探引擎时的密码 

Install Kernel Driver：安装底层嗅探驱动，嗅探底层驱动必须安装

且在同一台主机中只用安装一次。如果仅仅为了升级嗅探引擎，底层驱动可以不
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用安装。 

Install Program Only：安装嗅探引擎，嗅探引擎依赖于底层嗅探驱动。 

扫描引擎的服务名称为 NetCore，默认监听的端口为 1122。 

☺ 如果需要在本地主机进行嗅探（所在的局域网段），必须在本地安装嗅

探引擎。 

 

4 快速使用指南 

＊ 以下部分提供快速的使用指南，不包括详细的解释，适用于初次使

用的用户。如果以前曾经使用过流光，建议跳过这一部分。 
＊ 在此部分不包括有关参数的详细描述。 
＊ 在本章中标注有“＊”的部分不作详细解释，“＊”部分内容的说明

放在后面章节。 

4.1 界面说明 

启动流光之后，会出现如下的界面： 
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各部份功能 
1: 暴力破解的设置区域，这个区域主要用于设置暴力破解和其他相关的辅助功能。 

2：控制台输出，用于查看当前工作的状态，包括扫描和暴力破解等。 

3：扫描出来的典型漏洞列表，在这个列表中大多数情况都可以直接点击，对漏洞加以进

一步的验证。 

4：扫描或者暴力破解成功的用户帐号。 

5：扫描和暴力破解的速度控制（通过设置 TCP的超时时间来实现）。 

6：扫描和暴力破解时的状态显示，包括并发的线程数目和扫描速度等。 

7：中止按钮，可以中止暴力破解和扫描（IPC的暴力破解除外）＊。 

 

4.2 漏洞扫描 
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4.2.1 启动 

从菜单[Scan]->Advance Scanning（或者按 CTRL+A），就可以出现扫

描的设置窗口。 

4.2.2 设置 

4.2.2.1 范围设置 

流光的扫描包含很多内容，可以根据不同的需要进行选取。 

 
 

扫描的范围可以指定为一个或多个网段，但是这个范围内所包括的主机数目

最多不能超过 5000台（大约相当于 19个 C段）。 

在 Scan Item中，可以选择需要扫描的内容，只有需要扫描的内容，才会

出现在相应的设置窗口中。 

在 Target OS中可以选择相应的操作系统，扫描引擎可以根据对操作系统

的判断，只扫描被选择的操作系统主机。在默认情况下对所有的操作系统进行扫
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描。 

 

选项说明（选项以选中为例进行说明） 
Get Server Name: 获取主机的名称(Hostname) 

Ping First：在扫描之前，首先 PING 目标主机，如果能够 PING 到才扫描。这样做的

好处在于可以过滤掉大量不存在的 IP 地址以节约扫描时间，但是也会因此而漏掉一些不

响应 PING的主机。 

4.2.2.2 设置端口扫描 

点击 PORT标签，进入端口扫描设置（需要选中 PORT扫描项，此标签才会

出现）。 

 

端口是指 TCP端口，不包括 UDP端口。 

选项说明（选项以选中为例进行说明） 
Scan Stand Port: 扫描默认的标准端口，大约包含 50多个标准服务开放的端口。 

Customize Scan Port：自己定义扫描端口的范围，可以在 1-65535间选择。 

扫描引擎对 TCP端口扫描时采用标准的 TCP-Connect的方式进行扫描，
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所以并不能判断被防火墙过滤掉的开放的端口。 

4.2.2.3 设置 POP3扫描 

点击 POP3标签，进入 POP3扫描设置（需要选中 POP3扫描项，此标签才

会出现）。 

 

 

选项说明（选项以选中为例进行说明） 
Get POP3 Banner: 扫描 POP3服务的 Banner。 

Brute Wick Password：尝试用简单的字典对 POP3中的帐号进行暴力破解。 

Brute Wick Password所选择的字典包括用户名字典和密码字典。 

用户名字典：［Setup_Dir］\Brute.ult 

密码字典：[Setup_Dir]\Brute.dic 

＊如果扫描引擎已经通过其他途径获得了用户列表（例如通过 Finger），那么

用户名字典将会被用户列表代替。 
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4.2.2.4 设置 FTP扫描 

点击 FTP标签，进入 FTP扫描设置（需要选中 FTP扫描项，此标签才会出

现）。 

 

 

选项说明（选项以选中为例进行说明） 
Get FTP Banner: 扫描 FTP服务的 Banner。 

Detect Anonymous Login：检测是否能进行匿名登录。 

Brute Wick Password：尝试用简单的字典对 FTP中的帐号进行暴力破解。 

4.2.2.5 设置 SMTP扫描 

点击 SMTP标签，进入 SMTP扫描设置（需要选中 SMTP扫描项，此标签才

会出现）。 
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选项说明（选项以选中为例进行说明） 
Get SMTP Banner: 扫描 SMTP服务的 Banner。 

Detect EXPN/VRFY：检测是否使用 EXPN和 VRFY命令进行用户名验证。 

4.2.2.6 设置 IMAP扫描 

点击 IMAP标签，进入 IMAP扫描设置（需要选中 IMAP扫描项，此标签才

会出现）。 
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选项说明（选项以选中为例进行说明） 
Get IMAP Banner: 扫描 IMAP服务的 Banner。 

Try to Brute Wick Password：尝试用简单的字典对 IMAP中的帐号进行暴力破解。

4.2.2.7 设置 Telnet扫描 

点击 TELNET标签，进入 TELNET扫描设置（需要选中 TELNET扫描项，

此标签才会出现）。 
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选项说明（选项以选中为例进行说明） 
Get Telnet Banner: 扫描 Telnet服务的 Banner。 

SunOS Login Remote Exploit：扫描 SunOS /bin/login远程溢出弱点。 

4.2.2.8 设置 CGI扫描 

点击 CGI标签，进入 CGI扫描设置（需要选中 CGI扫描项，此标签才会出

现）。 
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选项说明（选项以选中为例进行说明） 
Get Web Server Banner: 扫描 WEB服务的 Banner。 

Automatic Select Rules Via OS：根据 WEB服务的版本自动选择 CGI的扫描规则，

这一选项适用于大多数系统。 

HTTP 200／500 Enable Only：仅仅对于 HTTP 返回的 200／500 认为是提交的规则

成功。否则除了 404（页面没有找到）以外都视为成功。 

CGI的扫描规则分为基于 IIS的和非 IIS的两大类，具体的 CGI规则设置

参见下一节。 

4.2.2.9 设置 CGI扫描规则 

点击 CGI RULES 标签，进入 CGI RULES 扫描设置（需要选中 CGI 扫描

项，此标签才会出现）。 
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在选择列表中，可以根据需要选择需要检测的 CGI 规则，默认情况下所有

规则都会被选取。 

CGI规则可以根据需要加入。 

4.2.2.10 设置 SQL扫描 

点击 SQL标签，进入 SQL扫描设置（需要选中 SQL扫描项，此标签才会出

现）。 
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选项说明（选项以选中为例进行说明） 
Get SA Password Via IIS: 尝试通过 IIS的漏洞获得 SA的密码。 

Brute Wick Password：尝试用简单的字典对 SQL中的帐号进行暴力破解 

SQL Server 2000 Information Gather：扫描 SQL Server 2000 暴露的系统信

息。 

4.2.2.11 设置 IPC扫描 

点击 IPC标签，进入 IPC扫描设置（需要选中 IPC扫描项，此标签才会出

现）。 
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选项说明（选项以选中为例进行说明） 
Establish NULL Session: 尝试和目标主机建立空连接。 

Enumerate Share Resource：枚举共享资源，并尝试是否具有密码保护。 

Enumerate User List：枚举用户列表 

Brute Force if Enumerate Succussifully: 如果获得了用户列表，就尝试暴力

破解。 

Brute Force Administrators Group Only：仅仅尝试属于 Administrators组

的用户 

 

如果没有获得用户列表，就不会尝试暴力破解。流光 5中对 IPC的暴力破

解采用了 SMB的机制，和以前版本的 API调用相比较，速度有大幅度提高。 

4.2.2.12 设置 IIS扫描 

点击 IIS标签，进入 IIS扫描设置（需要选中 IIS扫描项，此标签才会出

现）。 
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选项说明（选项以选中为例进行说明） 
Unicode Holes: 扫描 Unicode编码漏洞 

FrontPage Extension：扫描是否安装了 FrontPage 扩展 

Try to Get SAM：尝试获得 SAM(Security Accounts Manager)文件 

Try to Get PCAnywhere Password File: 尝试获得 PCAnywhere的密码文件 

此项扫描仅仅对安装了 IIS 的 Windows NT系统和 Windows 2000有效。 

4.2.2.13 设置 Finger扫描 

点击 Finger标签，进入 Finger扫描设置（需要选中 Finger扫描项，

此标签才会出现）。 
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选项说明（选项以选中为例进行说明） 
Finger User: 从给定的用户列表中对用户进行过滤，尝试得到正确的用户名。 

Enemurate User Name：对 SunOS和 Sco系统尝试获得用户列表 

4.2.2.14 设置 RPC扫描 

点击 RPC标签，进入 RPC扫描设置（需要选中 RPC扫描项，此标签才会出

现）。 
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选项说明（选项以选中为例进行说明） 
Get RPC Program ID: 获得 RPC的 Program ID 

4.2.2.15 设置 MISC扫描 

点击标签，进入 MISC扫描设置（需要选中 MISC扫描项，此标签才会出现）。 
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选项说明（选项以选中为例进行说明） 
Get Bind Version: 获得 BIND的版本号 

Brute MySQL Accounts：尝试获得 MySQL的帐号 

Get SSH Version：获得 SSH的版本号 

4.2.2.16 设置 PlugIn扫描 

点击标签，进入 PlugIn 扫描设置（需要选中 PlugIn 扫描项，此标签才

会出现）。 
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默认的插件说明 
FrontPage 2000 Extension Exploit: 检测 FrontPage 2000 扩展远程溢出 

IIS 5.0 NULL .Printer Exploit: 检测 IIS5.0 NULL.Printer远程溢出 

QPOP Verify User: 检测 QPOP验证用户名 

Sun OS FTP CWD Verify Username: 检测 SunOS的 FTP的 CWD命令验证用户名 

4.2.2.17 设置扫描选项 

关于扫描引擎工作的选项。 
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选项说明 
Brute Force User File: 尝试暴力破解的用户名字典，用于除了 IPC之外的项目。

此外，如果扫描引擎通过其他途径获得了用户名（例如通过 Finger 等），那么也不采用

这个用户名字典。 

Brute Force User File: 尝试暴力破解的密码字典 

Save Scan Result As：扫描报告的存放名称和位置，默认情况下文件名以[起始

IP]-[结束 IP].html为命名规则。 

Scan Threads: 扫描时并发的线程数目  

Option: 其他选项＊ 

4.2.3 选择扫描引擎 

流光的扫描引擎可以安装在不同的主机上，当然也可以直接从本地直接启

动。在完成了前面的扫描设置之后，需要做的事情就是决定使用什么地方（主机）

的扫描引擎来完成扫描工作。 
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扫描的引擎有两种工作方式：在线方式和后台方式。关于这两种方式的详细

说明将放在后面的章节[扫描的方式]说明。 

如果没有安装过任何扫描引擎，默认将使用本地的扫描引擎。 

选项说明 
Server：选择扫描引擎 

More：使用扫描引擎管理器＊ 

Port：扫描引擎监听的端口，本地的扫描引擎使用端口 3595 

Account: 用户名，本地扫描引擎用户名 LocalHost 

Password: 密码，本地扫描引擎密码为 LocalHost 

Show Detail…: 在线工作方式＊ 

Run as Daemon…:后台工作方式＊ 

Option: 后台工作方式的选项设置＊  

Option选项仅对后台工作方式有效。 

点击［START］即可开始扫描，在控制台输出中可以看到如下的内容： 
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当扫描完成后会得到一个扫描报告，里面会有扫描出来的弱点报告。 

4.2.4 其他 

当扫描引擎在工作时，可以在任何时候按下右下角的[STOP]按纽终止本次

扫描。 

4.3 暴力破解 

4.3.1 介绍 

流光的暴力破解部分包括 

POP3 

FTP 

IMAP 

HTTP Basic 

HTTP NTLM 

HTTP Proxy 

MSSQL 

IPC(SMB) 

在这一部分只进行通用的使用方法介绍，其他的特例和一些高级技巧将放在

暴力破解一节中介绍。 

其中还保留有 FORM 主机一项，目前此功能已经不能使用，取而代之的是功能更加
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强大的溯雪(DanSnow)。 
暴力破解的设置主要通过鼠标右键弹出的的菜单完成，需要注意的一点是：

当鼠标选择的目标不同（点击的项目不同），菜单的功能就不一样。 

4.3.2 参数设置 

4.3.2.1 设置主机 

4.3.2.1.1 新增 

选中需要进行暴力破解的主机类型（POP3、FTP等），点击鼠标右键，从弹

出的菜单中选择[Edit]->Add（也可以选中之后，直接按 Enter） 

 

加入主机的 IP或者名称。 

选项说明（选项以选中为例进行说明） 
Auto Regresh Host List: 自动刷新主机列表历史文件，所有曾经探测过的主机都将

会出现在下拉列表中。 

Auto completed：自动完成，根据历史记录文件尝试自动填满剩余的部分。 

主机可以加入多个，如果主机存放在一个现成的文件中，可以使用右键菜单

中的[Edit]->Add From List 

从文件对话框中选择含有主机名称或者 IP的列表文件，从中选择。 
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4.3.2.1.2 编辑 

选中需要编辑的主机，按［SPACE］，即可对选中的主机进行修改。 

4.3.2.1.3 删除 

选中主机，按［DEL］，即可删除选中的主机。 

也可以选中其上一级，按［DEL］，这样可以删除所有选中节点下面的子节

点（主机、用户等）。其效果等同于右键菜单[Edit]->Remove All。 

4.3.2.2 设置用户 

设置用户的时候，需要首先选中主机，用户作为主机下面的子节点。 

4.3.2.2.1 新增 

选中需要进行加入用户的主机，点击鼠标右键，从弹出的菜单中选择

[Edit]->Add（也可以选中主机之后，直接按 Enter） 

 

 

选项说明（选项以选中为例进行说明） 
Insert to Same Level: 插入同一级别的主机中，当同一层中有很多主机时，这个用

户名将会插入所有同层的主机中。 
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这种手工输入的方式适用于明确知道用户名的前提下，例如通过 Finger

或者其他漏洞已经拿到了用户名。 

在大多数的情况下，并不知道在这个系统中究竟有哪些用户，这时候可以采

用插入一个用户列表的方式来猜测（实际上除了破解成功的帐号外，还是不能确

定这个系统中究竟有哪些用户）。在渗透测试中，通常采用这样的方法寻找第一

个突破点。 

选中需要进行加入用户的主机，点击鼠标右键，从弹出的菜单中选择

[Edit]->Add From List。 

 
由于文件中用户数目过多，所以没有显示出整个文件中的每一个用户名，如

果需要显示，可以双击图中波浪线所示的节点（View All Items），即可展开

（如果已经展开，双击的效果相当于收缩）。如下图 
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4.3.2.2.2 编辑 

选中需要编辑的用户名，按［Space］，即可进行编辑。 

4.3.2.2.3 删除 

选中用户，按［DEL］，即可删除选中的用户。 

也可以选中其上一级，按［DEL］，这样可以删除所有选中节点下面的子节

点（主机、用户等）。其效果等同于右键菜单[Edit]->Remove All。 

4.3.2.3 设置密码 

选中[Decipher Dictionary or Scheme]，点右键，从右键菜单

[Edit]->Add。 

从文件列表对话框中选择字典文件或者方案文件。 

字典文件是包含了很多单词的文本文件，每一个单词占用一行。 

方案文件中并没有包含单词，它包含的是产生字典的规则。＊ 

 

字典可以同时使用多个。 

4.3.3 开始破解 

选中的需要破解的项目（包括主机、用户、字典等，确保相应的项目前面的

方框中打上对勾），没有打上对勾的项目不会被使用。 
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例如：上图中 192.168.0.105 虽然出现在列表中，但是由于没有选中，

所以不会对其进行暴力破解；192.168.0.100的 test没有被选中，所以再对

192.168.0.100的破解中，不会涉及到 test用户；同样，在字典设置中有两

个字典，但是只有被选中的才会被使用。 

4.3.3.1 简单模式破解 

菜单中[Scan]->Single Mode Scan，或者按 CTRL+F7。 

注意：简单模式不会使用设置的字典，而是用默认的简单模式字典

[Setup_dir]\Single.INI 

4.3.3.2 字典模式破解 

菜单中[Scan]->Dictionary Mode Scan，或者按 CTRL+F5，在字典

模式中，必须设置字典。 

4.3.4 停止破解 

按下右下角的[STOP]，即可以停止。 
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4.3.5 IPC（SMB）的破解 

在通常情况下，IPC只须填入主机名称，用户名可以通过枚举得到。 

4.3.5.1 枚举用户名 

对 IPC主机所在的树型列表中进行操作，可以具体到某一台主机，例如可以分别单
独开始或者停止某一台主机的探测或枚举。例如： 
 

 
 
在上图中，当前选中的只有 211.161.36.48,那么从菜单选择的命令只对一台主机

有效。 
红色标示：表示正在破解（猜测密码） 
绿色标示：表示正在枚举用户 
黑色标示：没有任何操作正在进行 
如果需要对所有主机（IPC）进行操作，那么就需要选中”IPC $ Server”。 
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选中需要进行枚举的主机，如果需要对列表中所有的主机进行枚举，请选

中”IPC$ Server”。从右键菜单中选择［Scan］->Get All IPC$ User List。 

 

 

 

选项说明（选项以选中为例进行说明） 
Brute User Who Belongs to Administrators: 仅仅破解属于 Administrators

组的用户。 

Stop Brute If Get Administrator Successfully: 只要成功破解出一个属于

Administrators组的用户，就停止对此主机的破解。 

[Yes]：在成功获得了用户列表之后，就自动开始破解。 

[No]: 不自动开始破解 

[Option]: 选项 

 

选项说明： 
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选项说明（选项以选中为例进行说明） 
Emenurate All Users: 枚举所有用户，否则就最多枚举 Limited中指定的用户数 

Add User From File If Emenurate Has Failed: 如果枚举失败，那么从指定的

文件中加入用户列表 

 

在某些系统中，用户数量非常多，如果枚举所有的用户会非常耗时。所以在

网络传输质量不是很好的环境中，不建议枚举所有用户。 

如果选择了自动开始破解，即[Yes]按纽，那么流光会自动使用密码字典

[Fluxay_Dir]\IPCSingle.INI. 

4.3.5.2 IPC破解 

如果通过上面的破解没有成功（或者没有选择自动开始破解），那么可以手

动开始对 IPC$的破解。 

选中需要探测的主机，从右键菜单中选择[Scan]->All IPC$ Remote 

Logon。 

 

 

选项说明（选项以选中为例进行说明） 
Use Single Burce Mode: 使用简单模式字典进行破解 

File：指定一个字典文件进行破解 

Brute Administrators Only: 仅仅破解属于 Administrators组的用户。 
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Stop Brute If Get Administrator Successfully: 只要成功破解出一个属于

Administrators组的用户，就停止对此主机的破解 

IPC的暴力破解采用了 SMB/CIFS的方式，所以破解成功的密码是没有区分大小写
的。 

例如：对于密码 Password/password/PASSWORD，破解出来的结果都是

password。 

4.4 网络嗅探 

本功能必须安装有网络适配器。 

4.4.1 安装 

流光 5中的嗅探是基于 ARP Spoof的，也就是说可以对大多数交换环境的

网络进行嗅探。嗅探也采用了 C/S 的结构，即使是对本地的局域网进行嗅探也

需要安装。 

安装的时候，必须开启 Server服务。 

具体过程参见安装本地嗅探引擎（需要网络适配器）。 

4.4.2 选择主机 

从菜单[Tools]->Remote Sniffer->Remote ARP Network Sniffer

或者按 ALT+S。 
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选项说明（选项以选中为例进行说明） 
IP: 安装嗅探引擎的主机，如果是本机则为 127.0.0.1 

Port：嗅探引擎监听的端口，默认为 1122 

Passwd: 连接嗅探引擎的密码 

Work Offline: 不连接主机，进入嗅探界面，此项功能主要用于打开历史嗅探记录。 

Connect: 开始连接指定的嗅探主机 

 

即使是连接本地主机，也需要在本地安装嗅探引擎。具体过程参见安装本地

嗅探引擎（需要网络适配器）一节。 

4.4.3 设置嗅探参数 

当连接成功后，就进入了设置的部分。 

 
 

选项说明（选项以选中为例进行说明） 
网卡: 选择需要嗅探的网卡，在某些系统中往往安装了多块网卡，选择不同的网卡，可以
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对不同的网络区域进行嗅探。 

Start IP：嗅探开始的 IP范围 

End IP：嗅探结束的 IP范围 

Gateway: 网关地址 

Protocol: 选择嗅探的 TCP或者 UDP数据包，根据选项的不同，下面出现的协议列表会

不同。 

Connect: 开始连接指定的嗅探主机 

Receive if (Not)Contain Keywords：仅仅接收（不）包含指定关键字的数据包 

Buffer：缓冲区长度，当缓冲区满了以后，会自动写入指定的记录文件 

LogFile：记录的嗅探文件，文件名+数字的形式线性增长。 

 

当选择了网卡以后，Start IP、End IP 和 Gateway 会根据网卡的设置

变化，通常情况下 Gateway地址不用更改。Start IP和 End IP的范围必须

在网卡设置的范围内。 

不要指定太大的 IP 范围，通常情况下宽带接入不要超过 64 个 IP，局域网不要超
过 255个 IP，否则流量太大，在某些情况下会引起安装嗅探引擎主机当机。 
根据需要选择需要嗅探的协议，只有被选中的协议类型才会被发送回客户界面。考

虑这一点的关键和流光和嗅探引擎的连接速度有关。 
如果指定关键字，则只会收到含有（或者不含有）指定关键字的数据包，这样也可

以减少数据传输的流量。每一个关键字用”;”间隔。 
遵循以上的规则，可以保证整个嗅探的可靠性和稳定性，请根据实际情况进

行设置，嗅探的数据并不是越多越好，而是在于数据的质量。 

设置完成后，按下［OK］，进入嗅探的主界面。 

4.4.4 开始嗅探 

嗅探监控的主界面 
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选项说明（选项以选中为例进行说明） 
Source: 源 IP地址 

SPort：源端口 

Dest：目标 IP地址 

DPort: 目标端口 

Protocol: 协议类型 

Content: 数据包摘要 

ID：数据包编号 

Start：开始嗅探 

Load：打开嗅探记录文件（仅用于 Work Offline模式） 

Refresh：和嗅探引擎重新建立连接，使用于连接情况不稳定的环境。 

Freeze：冻结屏幕滚动 

Stop：停止嗅探 
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按下[Start]，就可以通知嗅探引擎开始工作。 

 

 

区域 1：嗅探到的数据包列表。 

区域 2：显示选中的数据包。 

区域 3：控制台输出，用于查看嗅探引擎的工作情况。 

区域 4：嗅探网络的流量统计。 

4.4.5 终止 

按下［STOP］，即可停止嗅探。 

5 功能说明 

5.1 简单主机(漏洞)扫描 
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这个功能主要用于在一个大范围的网段中寻找开放了指定服务的主机。 

从[Scan]->Base Scanning启动或者按 CTRL+R。 

 

 

选项说明（选项以选中为例进行说明） 
Start IP: 扫描的起始 IP地址 

End IP：扫描的结束 IP地址 

Scan For：需要扫描的开放端口 

Insert SA: 对于发现的 MSSQL主机自动增加用户 SA 

Brute Force: 对某些类型的主机在发现的同时进行简单地暴力破解 

Insert FrontPage Host as HTTP Host: 对于安装了 FrontPage扩展的主机，插

入到 HTTP 主机列表中。这样做的目的主要在于可以通过 HTTP 的 NTLM 方式对系统帐号

进行破解。 

Add to Current Tree：将发现的主机插入相应的树型列表，例如将发现的 POP3主机

插入树型列表中 POP3分枝下。 

 

按下［OK］开始扫描。 
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当扫描完成后，会将这一类型的主机插入相对应的树型列表中。在这个例子

中，这些主机将被插入 IPC主机中。 

 

在下面会出现相对应的一些信息。 

:安装了 FrontPage主机的系统。 

：具有 UNICODE解码漏洞的主机，可以通过双击进入相对应的渗透工具。 

：开放了 RPC服务的主机。 

：安装了 PCAnyWhere，并且可以通过相关的漏洞获得用户密码文件。

可以通过双击进入相对应的渗透工具。例如： 

将密码文件通过远程上传至指定的 FTP主机，然后从 FTP下载到本地。 
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选项说明（选项以选中为例进行说明） 
FTP Server：上传的 FTP主机 

Username：FTP的用户名 

Password：FTP的密码 

FTP Filename: 上传后保存的文件名称 

IIS Detect CMD is Prohibited: 禁止远程系统检测 CMD，如果上传失败可以尝试

选择此项。 

 

上传成功后，可以下载到本地，并且利用相应的工具进行还原。

（[Tools]->Misc->PCAnyWhere Decipher）。 

 

密码还原的结果 

5.2 高级漏洞扫描 

此部分中将对漏洞扫描的各个模块进行详细描述，包括一些设置和使用的技

巧。建议以前用过流光的用户可以仔细阅读此部分。 
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5.2.1 设置指南 

 

 

在 Threads一项中，应该根据扫描引擎所安装的主机网络情况进行设置，

在 100M的网络环境中，可以设置为 200；其他情况下依次递减。 

点击［Option］，可以对扫描引擎的 Socket进行参数设置。 

 

 

选项说明 
Connect TimeOut：默认为 10000 毫秒。当扫描引擎对目标发起一个 TCP 连接时，如

果在指定的时间内没有得到响应，则认为此端口没有开放。扫描引擎所在的网络环境有良

好的速率，可以尝试减低此数值以提高扫描速度。 
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Data TimeOut:数据传送的超时设置。当连接成功建立后，Socket 在读写的时候最多

等待 10000毫秒（默认），如果没有任何数据，就产生一个超时，关闭连接。 

 

可以在扫描之前设置这些选项，也可以在扫描进行的过程中对这些选项进行

动态调整。调整的方式是直接用鼠标拖动界面左下方的滑动条。 

 
 

拖住图中红圈中方块，向左或者向右进行拖曳。越往右边超时设置越小，速

度越快，但是漏报率增高，反之亦然。 

5.2.2 扫描的方式 

扫描引擎的工作方式有两种，在线方式和后台方式。 

选择扫描引擎时，可以进行选择。 

 

 

选项说明 
Show Detail：在线方式，流光的界面和扫描引擎保持连接，扫描的信息实时通过加密

的隧道传送到界面。在此过程中，如果连接发生中断，那么扫描引擎将终止扫描。在这种

方式中，不能使用流光的其他的功能，直到本次扫描结束。 



 
流光 5用户手册                    

流光 5用户手册  第 62 页 共 158页 

Run as Daemon: 后台方式，流光把扫描的设置信息发送给扫描引擎后，就断开和扫描

引擎的连接。扫描引擎根据［Option］中设置，在扫描完成后，将结果发送给用户。这

种方式的优点在于可以做到无人监控，用户不必等待扫描结束就可以开始其他的工作。 

 

［Option］只有再选择了后台方式时且选择的主机不是 Localhost(本地)

时，才被激活。 

 
 

选项说明 
Notify Me Via SMS……：通过短消息通知用户扫描已经完成。 

Snd Mobile: 发送的手机号码 

Password：发送手机的密码 

Retr Mobile：接收的手机号码 

Notify Me Via E-Mail……：通过邮件通知用户扫描已经完成 

Attach PTR Files：在邮件中附上扫描结果文件 

Delete Swap File While……: 当邮件被成功发送后，删除扫描时产生的临时文件 

如 果 需 要 通 过 SMS 的 方 式 通 知 ， 那 么 首 先 需 要 到

http://sms.sina.com.cn为手机申请一个帐号，扫描引擎发送的 SMS都是
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通过新浪发送的。在设置了以后，最好按下［Test］进行测试。如果设置无误，

在 10多秒后，手机会收到一条测试信息，如图： 

 

如果通过邮件发送，那么当扫描完成后，可以根据需要直接把中间结果文件

通过邮件发送到用户的邮箱。 

以上两种方式可以同时选择。 

5.2.3 扫描报告 

在线方式的扫描报告会经扫描引擎和流光自动进行处理，不再赘述，在此主

要说明的是后台方式扫描报告的接收和处理。 

在扫描引擎存放的报告是经过 3DES加密的，只有发出扫描命令的唯一流光

版本才能接收和还原报告。 

5.2.3.1 手工接收报告 

如果仅仅通过短消息，没有通过邮件发送结果，那么需要手工接收扫描的报

告。 

从下图所示的菜单启动扫描接收功能。 
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[File]->Analysis Fluxay Sensor Result->Fluxay Sensor Scan 

History，或者按 Ctrl+E。 
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选项说明 
Host IP：扫描引擎的主机 IP地址 

More: 进入扫描引擎管理器（参见管理扫描引擎一节） 

Sensor Port：扫描引擎主机监听的端口 

Username：管理扫描引擎的用户名 

Password：管理扫描引擎的密码 

Remove：删除选中的报告（在扫描引擎的主机上） 

 

点击［Connect］，连接成功后，会返回所选择的扫描引擎的扫描记录。 

 
 

选择需要打开的报告，点鼠标右键，从弹出的菜单中选择。 

 

选项说明 
Open：从远程接收报告 

Open and Remove: 从远程接受报告，并且删除在扫描引擎上存放的副本 

 

接收之后会自动打开报告。 
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5.2.3.2 邮件报告 

如果通过邮件收到了扫描结果，按照以下步骤生成最终的扫描报告： 

1. 将邮件中的附件另存到指定的目录。 

2. [File]->Analysis Fluxay Sensor Result->Convert Fluxay 

Sensor PTR File，或者按 Ctrl+T。 

3. 从文件对话框中选择刚才另存的 PTR文件，点击［Open］。 

5.2.3.3 解密报告 

报告在接收到本地后，由流光使用设定的密钥进行解密，如果密钥不对将无

法得到正确的结果。如果在扫描之后修改了密钥（即扫描时的密钥和接收的密钥

不一致），那么请先改回原来的密钥，这样才能够得到正确的解密报告。 

5.2.4 插件 

流光的扫描提供了简单的插件功能，对一些新出现的漏洞可以通过写一个脚

本的方式加入流光的扫描规则中。 

插件文件的后缀名称为*.flux，存放在［Setup Directory］\Plugins

中。 

并且必须也放入［Setup Directory］\FluxaySensor\Plugins中。 

5.2.4.1 结构 

插件的一般形式： 

Name= 插件的名称，可以任意设置。 

Type= 适用的操作系统，NT和 UNIX两类。 

Detail=插件的详细描述，出现在最后的扫描报告中。 

port=目标的 TCP端口 

#start //开始 
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//执行的命令 

#start^ //结束，也是插件检测成功的标志。 

5.2.4.2 语法和命令 

Send=发送的字符串 

例如:send=GET / HTTP/1.0\0x0d\0x0a 

在字符串中，不可以打印字符用“\”作为转义字符，16进制表示。 

Recv＝接受的最大字符数目 

例如:Recv=100，最多接收 100个字符 

? 比较 

<> 包含 

！非，取反 

＝相等 

例如 

？<>TESTSTRING 表示是否含有“TESTSTRING”这个字符串 

？！<>404 PAGE NOT FOUND 表示是否不含有“404 PAGE NOT FOUND”

这个字符串 

5.2.4.3 例子 

FrontPage2000 扩展远程溢出的插件 

1) Name=FrontPage 2000 Extension Exploit 

2) Type=NT 

3) Detail=FrontPage 2000 Extension Exploit 

4) port=80 

5) #start 

6) send=HEAD /_vti_bin/_vti_aut/fp30reg.dll 
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HTTP/1.1\0x0d\0x0aHost:%host\0x0d\0x0a\0x0d\0x0a 

7) recv=100 

8) ?<>200 OK 

9) #start^ 

行号是为了解释方便而加入的，实际中的插件不需要行号。下面对每一行的

含义作详细解释： 

行 1：插件的名称，出现在扫描设置的 Plugins的列表中。 

行 2：对应检测的系统 

行 3：插件的详细描述，如果检测成功将出现在扫描报告中。 

行 4：连接目标主机的 TCP端口号 

行 5：程序开始标志 

行 6：发送一个 HTTP的请求 

行 7：接受 100个字符 

行 8：在接收的字符中是否含有字符串“200 OK”，如果有继续，否则中断

执行。 

行 9：结束，表示检测成功。 

再如 PlatinumFTPserver目录遍历的漏洞的插件编写如下： 

Name=Platinum FTP Server vulnerability 

Type=NT 

Detail＝Platinum FTP Server Directory traversal vulnerability 

Port=21  //默认 FTP的端口 

#start 

recv=1024   //接收 1024个字符 

?<> PlatinumFTPserver //判断是否为相应的 FTP版本 

send=user anonymous\0x0d\0x0a //匿名登陆 

recv=1024 
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?<> 331 //是否允许匿名登陆 

send=test@test.com\0x0d\0x0a 

recv=1024 

?<> 230 //登陆是否成功 

send= dir \..\..\..\..\..\ //目录遍历 

recv=1024 

?<>200 //命令被成功执行 

#start^ //结束 

 

目前流光的插件功能设计只能用于一些简单的场合，流光插件设计的最终目

的是希望达到 Nessus NASL的强大功能。 

5.3 暴力破解 

5.3.1 设置技巧 

暴力破解从原理上来说就是通过字典里面的单词进行逐个的猜解,经验和

一些技巧可以有效地提高破解的效率。 

假设以下几种情况来作说明，这些例子将尽量涵盖以上提到的经验和技巧。 

5.3.1.1 对一个网段的大范围扫描 

对一个网段进行大范围的特定主机的破解时，首先需要做的就是把这些系统

识别出来，为了达到这个目的，可以使用简单模式扫描（Base Scanning）。 

［Scan］->Base Scanning，或者 CTRL+R 
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设定扫描的范围，并且将 Scan For 一项设定为需要识别的服务类型，这

里我们设定为“NT/98”，点［OK］开始扫描。 

在 Base Scanning 中，在对特定的主机进行识别的过程中，还加入了其

他一些综合的技巧，以期能够扫描出一些常见的漏洞和密码。这些漏洞和密码会

被显示在流光的界面中。 

 

在这个例子中，我们扫描到一台主机有 UNICODE二次解码的漏洞。鉴于流

光是一个高度集成的渗透的工具，所以我们尽可能对一些攻击方法进行了封装，

使得其易于使用。 

单击该主机，从出现的菜单中选择［Connect］。 
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选项说明 
Allow IIS Detect CMD：允许 IIS检测到 CMD的存在，在某些情形下如果 IIS检测

到 CMD的存在，将会过滤执行的命令。这一选项可以根据需要灵活设置。 

点击［OK］，连接。可以在流光提供的界面中，对远程系统执行命令。 

 
 

在上面的例子中我们执行了一个 Ver命令。 

功能说明 
Local File <File Name>：从本地指定的文件中读取命令序列依次执行。 

Local Cls：清屏 

Local Open：使用浏览器，打开此站点的 WEB首页。 

Exit：退出 

上键：重复上一条命令 

下键：重复下一条命令 

在这个界面中，我们执行命令的权限通常很低，但是通过这个权限的 SHELL

就可以获得超级用户的权限。这已经超出了使用说明讨论的范畴，所以相关的资

料可以查阅有关的文档。 
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回到主题，扫描结束之后，可以看到所有被扫描出来的 NT/98主机已经被

列入了树型列表中。 

 
 

根据 4.3节中的说明，可以对所有主机进行密码猜测。由于流光 5采用了

SMB的 Base Negotiate的破解方法，对 NT/2000主机的破解速度极快，如

果简单模式没有猜测出来，可以换一个比较大的字典进行破解，不会花费太多的

时间。 

例如：将字典设置为 Password.dic。 

 

流光 5中 IPC扫描出来的密码是没有区分各种大小写组合的，所以如果在使用破解
出来的密码时，在某些情况下需要尝试大小写的变换。 

5.3.1.2 获得用户名 

NT/2000 可以通过 Null Session 获得用户列表，但是其他的系统就没
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有提供这个功能。 

通常对某些 UNIX系统，我们可以根据其他的服务来猜测用户名，这些服务

包括： 

Finger 

SMTP （VRFY/RCPT） 

Sun FTPD等 

5.3.1.2.1 Finger 

通过某些版本的 UNIX（SUNOS和 SCO）的 Finger服务可以得到部分用户

列表，这些 UNIX的版本通常可以通过漏洞扫描时得到。 

将这些主机加入树型列表中（例如加入 FTP 中，FTP 的帐号通常就是系统

的帐号）。 

 

从右键菜单中选择[Scan]->Sun solaris Emernurate……，就可以得

到部分用户列表。 
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可以看到，通过 Finger获得了 5个用户名，但是前面 4个都是没有 SHELL

的，所以对它们作暴力破解是没有意义的，只有第 5个用户才是真正具有 SHELL

的用户。有了用户名之后，就可以有针对性地对此用户进行暴力破解。 

5.3.1.2.2 SMTP 

SMTP服务本身并不能获得用户列表，但是可以通过他知道某一个用户是否

存在，这些可以通过 SMTP服务的 VRFY和 RCPT命令来实现。 

通常的做法是为一个 SMTP指定一个用户字典，让其从这个字典中筛选出存

在的用户。 

将主机加入树型列表中 SMTP一项，加入一个用户字典。 

 

 

从右键菜单中选择[Scan]->Verify User Via SMTP。 

流光会从指定的字典中过滤出存在的用户名。 
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获得了用户名后，将此主机加入树型列表中其他类型（FTP等可以猜测密码

的服务），从右键菜单中选择[Import]->Import From SMTP，就可以把这个

用户名导入相对应的用户列表中。 

 

 

5.3.1.2.3 SUN OS FTPD 

SunOS 某些版本（2.5-2.8?）的 FTP 和 SMTP 一样也可以提供验证用户

名的作用。 

将这种类型的主机加入树型列表 FTP 中，加入一个用户字典，从右键菜单

中选择［Scan］->Sun Solaris FTP Verify User。 
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流光会从指定的字典中过滤出存在的用户名。 

 

 

获得了 4个用户名，但是 sys和 adm是没有 SHELL，所以在下一步做破解

的时候不要选择这两个用户。 

5.3.2 选项 

5.3.2.1 系统设置 

在暴力破解中，需要根据网络的速度调整线程的数目，以保证破解的可靠性。

通常情况下，如果在破解的过程中出现大量的 Thread XXX NO Response(线

程没有响应)，说明需要将线程的数目降低。 

[Option]->System Options 
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如果选中 Auto Adjust Threads，那么在破解的过程中，会根据网络的

状况自动调整线程的数目。 

5.3.2.2 字典设置 

在暴力破解中，如果已经知道了用户名，那么在很多情况下密码就是用户名

本身加上数字构成。 

采用简单模式，并且在密码后面加上特定的字母后缀是成功率比较高的字典

组合。 

[Option]->Single Mode Option 

 

 

选项说明 
Add Suffix to Username：在用户名称后加后缀 

Double Username：双写用户名称，如:john->johnjohn 

Reverse Username：将用户名称反转，如 john->nhoj 
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Suffix File：后缀文件名 

Use Single.INI：使用简单模式字典文件 Single.INI, 如果不使用，那么简单模式

中字典就仅仅以用户名作为密码。 

5.3.3 字典和方案 

在暴力破解中，用户名字典和密码字典既可以使用字典文件，也可以使用方

案文件。 

字典文件就是一个一个单词组成的文件，每个单词用回车换行间隔。 

方案文件就是指定组合方式的文件，每一行的内容指定了单词中相应位置构

成，例如 

0123456789 

0123456789 

0123456789 

上面的这个方案文件就构成了所有 3位数字的所有组合(000-999)。 

在流光中，方案文件的后缀名称为*.sch，在指定方案文件的时候，采用指

定字典文件一样的方式。 

5.4 网络嗅探 

5.4.1 说明 

流光 5中网络嗅探是一个基于 ARP欺骗的报文捕捉工具，安装嗅探引擎的

主机分别向目标主机和网关发送 ARP 欺骗的报文，使得这些主机的数据通过安

装了嗅探引擎的主机进行转发。从这一点来说，相当于是一个中间人攻击。 

由于某些网络流量会非常大，所以通过这样的嗅探方式，有可能会出现丢包

率增高的现象。所以在设置嗅探范围的时候，不要设置过大的范围。同时考虑到

流光和嗅探引擎主机之间的连接速度，为了减少数据的流量，最好指定关键字过

滤，要知道拨号连接是不可能承担 100M网络环境流量的。 
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有关于 ARP欺骗的原理，可以查阅有关的文章。 

目前在 Linux 平台下面已经有了基于 ARP 欺骗的 Sniffer，但是大多数

都是一对一的欺骗，而且不具备远程安装、嗅探的特点。流光 5中 ARP Sniffer

是第一个基于 Win32 平台的、远程安装和控制的交换环境嗅探软件，在开发的

过程中，在大量的网络环境中进行了测试，证明了其可靠性和实用性。 

这是一个非常有用，同时也是一个非常危险的工具，因为在一个局域网内，

只要有一台主机被安装了嗅探引擎，那么整个网络的数据都可以被监听，包括一

些敏感的数据（例如没有加密的用户名和密码等）。 

流光作为一个高度集成的渗透工具，ARP Sniffer为渗透测试提供另一种

强大的支持。 

5.4.2 设置指南 

考虑这样一个网络环境，IP地址从 192.168.0.1-192.168.0.255，网

关为 192.168.0.1，所有的服务器都放在 DMZ（192.168.2.1-255网段）。 

在 192.168.0.16上面安装了嗅探引擎。 

以下面几个例子来说明 ARP Sniffer的用法。 

[Tools]->Remote Sniffer->Remote ARP Sniffer， 或者按 ALT+S。 

 

 

填入安装了嗅探引擎的主机 IP：192.168.0.16，端口默认为 1122，不

用更改。 
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连接成功以后，根据不同的需要进行设置。 

5.4.2.1 收集所有邮件信息 

进入设置部分 

 
 

嗅探的范围选择 192.168.0.1-192.168.0.255，因为邮件服务器是放

在 DMZ区，所以局域网内所有的 POP3和 SMTP数据进出都必须通过网关，网关

选为 192.168.0.1。这样设置以后，嗅探引擎就在局域网和网关之间充当了中

间人的角色，所有的数据都会通过嗅探引擎安装的主机进行转发。 

由于本次嗅探只关心有关于邮件的信息，所以协议只选择 SMTP和 POP3即

可。 

设置完成后开始嗅探，可以看到很快就捕捉到了数据包。 
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选择三个连续的 SMTP数据包（因为是同一个 MAIL），按右键，从出现的菜

单中选择[Save Packet As]，将选择的保存为 test.eml。 

用 Outlook Express就可以打开这封我们截获到的 MAIL，如图： 

 

5.4.2.2 收集所有邮件密码 

进入设置部分 
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由于只想得到用户名和密码，所以在设置的时候，除了和上文一致外，我们

加入了“USER;PASS”两个关键字进行过滤，这样嗅探引擎只会把含有 User 或

者 Pass的数据发给流光的界面。具体关键字的过滤根据协议不同而不同，不能

全部套用，例如 Telnet登陆的关键字就是“Login和 Password”。 

开始嗅探，不久就可以得到结果。 

 

5.4.2.3 监听局域网内某一台主机的所有通讯 

前面的两个例子说的都是嗅探局域网内的主机和外部之间的数据交换，如果

需要嗅探局域网内某一台主机和其他主机之间的数据交换，那么设置会有所不

同。 

例如 192.168.0.10是一台 SunOS，由于这台 SunOS是在局域网内，所

以能够登陆它的主机只能位于局域网内（一般情况下）。按照前面的设置方法，

是无法听到这台主机和内网之间的通讯的。在这样的情况下，我们只需要把网关
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改为 192.168.0.10就可以达到这个目的了（相当于嗅探引擎在局域网和这台

主机之间充当了中间人的角色）。 

 
 

由于 Telnet是明文传输的，所以选择 Telnet通常可以获得登陆的帐号。 
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从上面的结果可以看出，用户 mailsrv通过 Telnet登陆。 

5.4.3 选项 

5.4.3.1 端口过滤的设置 

端口过滤选择的所有设置都位于[Setup_Dir]\Protocol.INI中，格式

类型为： 

协议名称：类型：端口 

可以根据需要，自行增加新的协议类型，例如增加 VPN 

VPN：TCP：1723 

5.4.3.2 其他 

 
 

功能说明 
Load：从本地打开记录文件 

Refresh：刷新当前网络，再过一段时间后，嗅探的网络中可能会出现新的机器（开机）

或者消失一些机器（关机），所以需要进行刷新。 

Freeze：冻结屏幕滚动，便于查看当前捕获的数据包。 

 

当按下［Stop］停止嗅探以后，嗅探引擎不会立刻停止，而是需要等到当前的缓冲
区满了为止，这样设计的原因是平衡了丢包率和捕获数据效率之间的平衡。在此期间，网

络不受任何影响。 
嗅探引擎停止的时候会恢复各个相关主机的 ARP表，但是需要一定的时间（10秒左

右），在这段时间内相关主机有可能会出现网络连接故障。 
如果在嗅探过程中，嗅探引擎所在的主机关闭或者程序本身崩溃，会导致在一段时

间内相关的主机网络连接出现故障，故障恢复的时间取决于各主机 ARP 表的刷新时间，一
般从 30秒至 5分钟不等。 
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5.5 渗透工具 

5.5.1 NTCMD 

NTCMD是在远程 NT/2000系统中执行命令的工具，它位于[Setup_Dir]

中。 

用法： 

NTCMD \\<IP> -U:Username –P:Password 

Username必须具有 Administrators权限。 

例如： 

 

5.5.2 SQLRCMD 

SQLRCMD是远程连接 MSSQL的工具，利用 XP_CMDSHELL获得 NT/2000

的 SHELL。 

SQLRCMD有两个版本，分别位于 

[Setup_Dir]\SqlRCmd\SqlRCmd_Express （适用于本机已经安装了

SQLServer） 

和 

[Setup_Dir]\SqlRCmd\SqlRCmd_Normal （适用于本级没有安装

SQLServer）。 
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两个版本的用法都是一致的。 

SqlRCmd IP Username Password 

其中 Username和 Password指的是 SQL数据库的用户名和密码。 

例如： 

 

5.5.3 TCPRelay 

TCP Replay是一个 TCP端口转发的工具，用法如下： 

TCPRelay ListenPort IP Port 

ListenPort：监听的端口 

IP：转发的目的 IP 

Port：转发的目的端口 

例如： 

 

监听端口 99，并将 99 端口的连接转发到 211.100.6.134 的 23 端口

(Telnet)。 

这个时候如果连接端口 99： 
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实际上相当于连接到了 211.100.6.134的 23端口。 

5.5.4 SRV 

实际上是 NCX99，运行以后在端口 99监听，对此端口的连接返回一个 CMD

的 SHELL。 

SRV被许多防病毒软件作为病毒查杀，这个文件实际上并没有什么危害。 

5.5.5 BINDSHELL 

顾名思义 BINDSHELL 就是绑定 SHELL 的意思，和 SRV 不同的是，

BINDSHELL不但可以指定绑定的端口，同时也可以提供反向连接，以达到绕过

访问控制的目的。 

用法： 

BindShell Port 监听指定的端口，对此端口的连接返回 SHELL 

BindShell -R IP Port 反向连接，连接到指定 IP的 Port，提供 SHELL 

第一种情况很普遍，不再一一详细解释，下面的例子是针对第二种用法的。 

 

反向连接到指定 IP的指定端口。 

在指定 IP的指定端口监听，等待 BindShell的连接。 
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连接成功，获得了远程主机的 SHELL。 

5.5.6 IPC种植者 

IPC种植者利用管道（Pipes）和 NT的定时服务上传并且启动指定的应用

程序。由于利用了定时服务的关系，在设定成功后，应用程序最多在 60秒内会

被执行。 

[Tools]->NT/IIS Tools->IPC Planter 

 

 

选项说明 
Host IP：远程主机的 IP地址 

Username：远程主机的用户名(必须具有超级用户的权限) 

Password：远程主机的密码 
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Local File：本地的文件 

Remote File：复制到远程主机的文件名 

Command：执行的命令，可以加选项 

 

成功地设置以后，最多等待 60秒，指定的程序就会被启动。在上个例子中，

BindShell启动后，会在远程主机上面开启 99端口。 

 

 

5.6 字典工具 

流光中有大量的工具供用户产生字典，这是由于流光开发最初是设计成为一

个纯粹的暴力破解工具，所以字典工具就必不可少。 

5.6.1 产生字典 

从[Tools]->Dictionary Tools->Ultra Dict……启动字典工具。 
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5.6.1.1 设置 

 

 

选项说明 
Alpha：使用字母组合 

Num：使用数字组合 

Symbol：使用符号组合 

 

指定参加组合的字母个数和数字个数，例如 3 个字母和 2 个数字这样的形

式的单词类型：aaa00。 

指定参加字母的范围和数字的范围：From A to Z, From 0 to 9。 
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5.6.1.2 选项 

 

 

选项说明 
Upper Case：使用大写字母 

Upper First：第一个字母大写 

Num First：在有字母和数字的组合时，数字放在前面。 

Use LF Space：仅仅使用换行符号作为间隔，缺省情况下采用回车换行符号作为间隔。

User Consonant Only: 仅仅使用字母范围中的辅音字母 
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5.6.1.3 保存文件 

 

 

选项说明 
Browse：指定保存的字典文件名称 

Spilit：将字典文件分割为指定的份数 
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5.6.1.4 高级选项 

 

 

选项说明 
Use This Option……：使用上面的设置规则产生字典 

Use Schedule：使用方案文件产生字典 

 

这两种方式在同一时刻，只能选择一种。 

Use This Option……的方式可以指定单词中每一位的组成范围，例如在

上面的例子中，产生的单词第一位是数字，第二位是字母，第三位是符号…以此

类推。 

在这种方式中，参加组合的字母和数字的范围仍然取决于［设置］中的设定。 

Use Schedule 的方式是采用方案文件的规则来产生字典，在这种方式中

所有产生的规则都由方案文件决定，和其他设置无关。 
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5.6.1.5 保存方案 

 

 

选项说明 
Writing to Schedule File：将当前的字典产生规则存入指定的方案文件 

Browse：指定保存的方案文件名 

 

可以把当前产生字典的规则保存在一个方案文件中，以便下次直接使用这个

方案文件产生字典。 

5.6.1.6 产生字典 

一切设置无误后，点［OK］，出现一个预览窗口。 
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从这里可以看到产生的字典的形式，确认无误后，按［Start］字典即可生

成。 

5.6.2 字典的规则 

除了可以按照组合的方式产生字典以外，还可以按照一定的规则产生字典，

例如按照中文拼音的规则和英文的规则等等。 

以中文的拼音规则为例 

［Tools］->Dictionary Tools->Chinese PinYin Regula 
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根据拼音的音节来组合产生单词，最多可以设置三组音节。 

选项说明 
Limit 8 Characters：最多 8个字符，如果按照规则产生的单词超过了 8位，那么将

被舍弃。 

？： 进入字典分割菜单（关于分割字典，参见功能列表中的相关说明） 

5.7 杂项工具 

5.7.1 管理扫描引擎 

为了便于对大量的扫描引擎进行管理和维护，流光专门设计的扫描引擎的管

理工具。 

5.7.1.1 管理扫描引擎 

[Tools]->Fluxay Sensor tools->Manager Fluxay Sensor 
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列表中显示的是曾经安装过的扫描引擎的状态，点击[Detect]可以检测这

些扫描引擎目前的状态。 

 

绿色主机表示扫描引擎工作正常，可扫描，可管理。 

红色主机表示扫描引擎故障，不可扫描也不可管理。 

黄色主机表示扫描引擎或者控制接口其中止已出现故障，从 Status 中可

以看出具体是哪一部分出现了故障。 

C:ERR S:OK 表示控制接口出现了问题，但是扫描引擎工作正常。 

C:OK S:ERR 表示控制接口工作正常，但是扫描引擎出现故障 

控制接口负责扫描引擎的维护、升级。如果控制接口出现了问题，即使扫描引擎工

作正常，也不能进行升级更新。 

Build一栏显示的扫描引擎的版本信息。 

Status 显示目前扫描引擎的状态，IDLE 0/0 表示空闲可用;Scanning 

x/y表示正在扫描，共有 y台主机，目前已经扫描了 x台;Stopping表示正在

中断扫描引擎当前的工作。 
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Ping显示和扫描引擎的响应时间，通常情况下这个数值越小，说明连接速

度越快。 

Remark： 注释 

在选中的主机上双击左键，可以修改注释。 

 

点击［Remove］可以将选中的主机从管理列表中删除，但是并没有真正从

系统中删除扫描引擎，扫描引擎的删除见下面有关章节。 

点击［Add］进入扫描引擎安装界面，扫描引擎的安装参见第三部分［开始

之前］相关的部分。 

5.7.1.2 升级扫描引擎 

扫描引擎的升级是通过控制接口来进行的，通常情况下，流光会自动检测是

否有新版本的扫描引擎可供下载，也可以通过[About]->Check Update来检

查更新情况。 
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本 地 升 级 只 须 将 将 新 的 扫 描 引 擎 文 件 保 存 在

[Setup_Dir]\FluxaySensor目录中，同名覆盖原来的文件即可。 

对远程的扫描引擎进行升级，需要通过流光提供的工具来进行。 

[Tools]->Fluxay Sensor Tools->Update Fluxay Sensor 

 

 

选项说明 
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Sensor IP：需要升级的扫描引擎 IP 

More：进入扫描引擎管理器 

Username：安装扫描引擎时设定的用户名（不是系统的用户名） 

Password：安装扫描引擎时设定的密码（不是系统的密码） 

Control Port：控制接口监听的端口 

Update File：新的扫描引擎文件 FluxaySensor.exe 

 

在升级成功后，扫描引擎会自动重启。 

5.7.1.3 删除扫描引擎 

删除扫描引擎需要系统的用户名和密码，并且必须具有超级用户的权限。 

[Tools]->Fluxay Sensor Tools->Remove Fluxay Sensor 

 
 

选项说明 
Host IP：需要删除的扫描引擎 IP 

NT Account：系统用户名 

Password：系统密码 

ServiceName：服务的名称，此项不能填错，否则不能删除扫描引擎或者删除其他的系

统服务。 
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5.7.2 管理嗅探引擎 

为了便于对大量的嗅探引擎进行管理和维护，流光为此专门设计的嗅探引擎

的管理工具。 

5.7.2.1 管理嗅探引擎 

[Tools]->Remote Sniffer->Manager ARP Network Sniffer 

 

列表中显示的是曾经安装过的嗅探引擎的状态，点击[Detect]可以检测这

些嗅探引擎目前的状态。 

绿色主机表示嗅探引擎工作正常。 

红色主机表示嗅探引擎故障。 

黄色主机表示不能获得嗅探引擎的信息，通常情况下是由于密码错误引起

的。 

Build：显示嗅探引擎的版本信息。 

Port：显示嗅探引擎监听的端口。 

IP From：显示嗅探引擎可以工作范围的起始 IP地址 
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End IP：显示嗅探引擎可以工作范围的结束 IP地址 

Gateway：网关 

TTL：显示嗅探的响应时间，通常情况下这个数值越小，说明连接速度越快。 

5.7.3 其他 

5.7.3.1 PCAnyWhere密码还原 

PCAnyWhere 的密码文件并没有经过加密，而只是进行了简单地变换，利

用这个工具可以轻松地还原被变换了的密码。 

[Tools]->Misc Tools->PCAnyWhere Password Decipher 

选择一个 PCAnyWhere的密码文件，通常是*.CIF，密码就会被还原。 

 

5.7.3.2 从 UNIX密码文件提取用户名 

从 UNIX的 Passwd中提取用户名存入指定的用户列表文件，以便在暴力破

解时使用。 

6 功能列表 

6.1 文件功能 

6.1.1 Advance Scan Wizzard 

9 快捷键 
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Ctrl+W 

9 功能说明 

高级扫描设置向导，通过向导的形式一步一步的对高级扫描进行设置。设置

的详细说明参见 5.1节。 

6.1.2 New Project 

9 快捷键 

Ctrl＋N 
9 功能说明 

新建一个项目，这个命令将会清除目前流光界面中的所有内容。 

6.1.3 Open Project 

9 快捷键 

Ctrl＋O 
9 功能说明 

打开一个已有的项目（*.flx） 

6.1.4 Save Project 

9 快捷键 

Ctrl+S 
9 功能说明 

保存当前的项目(*.flx) 

6.1.5 Save Project As 

9 快捷键 

Ctrl+Shift+S 
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9 功能说明 

将当前的项目另存（*.flx） 

6.1.6 Last Project 

9 快捷键 

N/A 
9 功能说明 

打开最近一次项目，通常在流光启动的时候会自动执行这个命令。 

6.1.7 Recent Result (SubMenu) 

6.1.7.1 Recent Result 

9 快捷键 

N/A 
9 功能说明 

打开最近的扫描／探测结果。 

6.1.7.2 Make Report 

9 快捷键 

N/A 
9 功能说明 

根据最近的扫描／探测结果生成报告（HTML格式）。 

6.1.8 History Result (SubMenu) 

6.1.8.1 History Result 

9 快捷键 

N/A 
9 功能说明 
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打开历史扫描／探测结果。 

 

 

功能说明(以选中为例) 
Search：根据关键字在结果中查找。 

6.1.8.2 Make Report 

9 快捷键 

N/A 
9 功能说明 

根据历史扫描／探测结果生成报告（HTML格式）。 

 

6.1.9 Import Result (SubMenu) 

6.1.9.1 Import Result 

9 快捷键 

N/A 
9 功能说明 

从以前版本的流光中导入探测/扫描结果。 
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功能说明(以选中为例) 
Browse：选择以前版本流光的安装目录。 

Filter Result：在导入的时候，对已经存在的重复项进行过滤。 

 

6.1.10 Analysis Fluxay/FluxayShadow Result (SubMenu) 

6.1.10.1 Fluxay/FluxShadow Result Anal&ysis... 

9 快捷键 

N/A 
9 功能说明 

分 析 流 光 / 流 影 ( 关 于 这 个 系 列 软 件 的 情 况 请 参 见

http://www.netXeyes.org/snow.html)的扫描结果。 

6.1.10.2 Make Report 

9 快捷键 

N/A 
9 功能说明 

根据流光/流影的扫描结果生成报告(HTML格式)。 
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6.1.11 Analysis Fluxay Sensor Result (SubMenu) 

6.1.11.1 Fluxay Sensor Scan Histroy 

9 快捷键 

Ctrl+E 
9 功能说明 

对流光扫描引擎的扫描记录进行管理。 

 

 

功能说明(以选中为例) 
Host IP：选择流光扫描引擎安装的主机 

More：进入扫描引擎管理器 

Sensor Port：扫描引擎监听的端口 

Username：连接扫描引擎的用户名 

Password：连接扫描引擎的密码 

Remove：从列表中删除扫描引擎（仅仅从列表中删除，并没有真正卸载） 

Connect：连接指定的扫描引擎 

当填入了扫描引擎的相关信息后，按[Connect]，可以得到这个扫描引擎

以往的历史扫描记录。 



 
流光 5用户手册                    

流光 5用户手册  第 108 页 共 158页 

 

在需要接收选择的报告中点右键 

 

 

功能说明(以选中为例) 
Open：打开报告(将报告传送到本地) 

Open and Remove：打开报告，并且在成功之后在扫描引擎中删除此报告 

 

在远程存放的实际上是加密的报告中间文件形式，而并不是报告本身。在接收报告

之后，流光会用当前的密钥对此报告进行解密并产生报告。如果当前的密钥和控制扫描引
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擎时的密钥不一样，将无法得到正确的扫描报告。 

6.1.11.2 Convert Fluxay Sensor PTR Files 

9 快捷键 

Ctrl+E 
9 功能说明 

根据选择的扫描引擎中间文件(*.ptr)产生报告。 

6.1.12 Open Report 

9 快捷键 

N/A 
9 功能说明 

打开本地的历史扫描报告。 

 

 

列表中将会出现所有在本地的扫描报告，通过左键点击菜单[Open]可以打

开并阅读。报告的格式均为 HTML格式。 
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6.1.13 Exit 

9 快捷键 

Alt＋F4 
9 功能说明 

退出流光。 

当流光在退出的时候，会自动记录当前的项目，保存为 Last.flx，并在下

次启动的时候自动打开。 

在退出流光前应该首先关闭正在进行的扫描。 

当流光的扫描任务没有结束的时候，使用此命令将仅仅关闭界面，而流光不会真正

退出，直到扫描任务完成。 

6.2 编辑功能 

编辑功能通常情况下需要在树型列表中选中某一项目时才可用，其功能对

应于树型列表中在选中列表中点右键出现的菜单。 

6.2.1 Edit 

9 快捷键 

Space 
9 功能说明 

编辑选中的项目。 

6.2.2 Add (SubMenu) 

6.2.2.1 Add Host 

9 快捷键 

Enter 

9 功能说明 
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在树型列表中增加一个主机（域名或者 IP）。 

6.2.2.2 Add Host From List 

9 快捷键 

N/A 

9 功能说明 

从指定的主机文件列表中增加一个或者多个主机道选择的树型分支中。 

6.2.2.3 Add User 

9 快捷键 

Enter 

9 功能说明 

在选定的树形列表中增加一个用户。 

6.2.2.4 Add User From List 

9 快捷键 

N/A 

9 功能说明 

从指定的用户文件列表中增加用户到选择的树型分支中主机下面。 

6.2.2.5 Add Dictionary 

9 快捷键 

Enter 

9 功能说明 

在树型列表中增加一个字典文件。 

6.2.2.6 Add Schedul 

9 快捷键 

N/A 

9 功能说明 

在树型列表中增加一个方案文件。 
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6.2.3 Remove (SubMenu) 

6.2.3.1 Remove User 

9 快捷键 

DEL  

9 功能说明 

从选定的树型列表中删除一个用户。 

6.2.3.2 Remove All User 

9 快捷键 

DEL 

9 功能说明 

从选定的树型列表中删除其分支下的所有用户。 

6.2.3.3 Remove Current Host 

9 快捷键 

DEL 

9 功能说明 

从选定的树型列表中删除选定的主机。 

6.2.3.4 Remove All Hosts 

9 快捷键 

DEL 

9 功能说明 

从树型列表中删除选中的分下的所有主机，此项操作将同时删除主机下的所

有用户。 

6.2.3.5 Remove Dictionary or Schedule 

9 快捷键 

DEL 
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9 功能说明 

删除树型列表中的字典或者方案。 

6.2.4 Import (SubMenu) 

6.2.4.1 Import From SMTP Host 

9 快捷键 

N/A 

9 功能说明 

将 SMTP主机中的用户导入当前选定的树型列表主机分支中。 

6.2.4.2 Import From IPC$ Host 

9 快捷键 

N/A 

9 功能说明 

将 IPC$主机中的用户导入当前选定的树型列表主机分支中。 

6.2.5 Export (SubMenu) 

6.2.5.1 Export to SQL Host 

9 快捷键 

N/A 

9 功能说明 

将在树型列表分支中选中的主机下面的所有用户导入 SQL分支主机中。 

6.2.6 Export to IPC Host 

9 快捷键 

N/A 

9 功能说明 
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将在树型列表分支中选中的主机下面的所有用户导入 IPC分支主机中。 

6.3 查看选项 

6.3.1 Expand 

9 快捷键 

Shift+E 

9 功能说明 

展开选择的树型列表项目的所有子项目。当项目过多时此项操作可能会相当

消耗时间和系统资源。 

6.3.2 Collapse 

9 快捷键 

Shift+C 

9 功能说明 

折叠选择的树型列表项目的所有子项目。 

6.3.3 View Password 

9 快捷键 

N/A 

9 功能说明 

查看在树型列表中选择的用户密码。 

6.3.4 Sort 

9 快捷键 

F2 

9 功能说明 
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将选中的树型列表中的项目排序。 

6.3.5 Refresh 

9 快捷键 

F5 

9 功能说明 

刷新显示。 

6.4 扫描功能 

6.4.1 Single Mode Scan 

9 快捷键 

Ctrl+F7 

9 功能说明 

简单模式暴力破解。 

6.4.2 Dictionary Mode Scan 

9 快捷键 

Ctrl+F5 

9 功能说明 

字典(方案)模式暴力破解。 

6.4.3 Restore From Break Poit 

9 快捷键 

N/A 

9 功能说明 

从上次破解的中断处继续恢复暴力破解。 



 
流光 5用户手册                    

流光 5用户手册  第 116 页 共 158页 

6.4.4 Port Scan 

9 快捷键 

N/A 

9 功能说明 

对在树型列表中选定的主机进行端口扫描。 

6.4.5 Detect Host OS 

9 快捷键 

N/A 

9 功能说明 

对树型列表中选定的主机进行操作系统识别。 

6.4.6 Finger User 

9 快捷键 

N/A 

9 功能说明 

对选中的主机尝试利用 Finger功能获取用户列表。 

6.4.7 Sun OS Finger Forward 

9 快捷键 

N/A 

9 功能说明 

对选中的主机(SunOS和 SCO)的 Finger弱点，获得用户帐号名称。 

6.4.8 Sun Solaris FTP Verify User 

9 快捷键 
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N/A 

9 功能说明 

对选中的主机(SunOS)FTP的弱点，尝试获得用户帐号名称。 

6.4.9 SMTP Expn User 

9 快捷键 

N/A 

9 功能说明 

对选中的 SMTP主机利用 EXPN命令尝试获得用户帐号名称。 

6.4.10 Ememurate IPC$ User 

9 快捷键 

Ctrl+F9 

9 功能说明 

从选定的 IPC主机中枚举用户信息。 

6.4.11 Logon IPC$ Host 

9 快捷键 

Ctrl+F10 

9 功能说明 

尝试用获得用户名登陆 IPC主机。 

6.4.12 Advance Scanning 

9 快捷键 

Ctrl+A 

9 功能说明 
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启动漏洞扫描程序。 

6.4.13 Base Scanning 

9 快捷键 

Ctrl+R 

9 功能说明 

启动简单漏洞扫描程序。 

6.5 系统选项 

6.5.1 Connect Option 

9 快捷键 

N/A 

9 功能说明 

此项功能已经没有实际作用。 

6.5.2 System Option 

9 快捷键 

N/A 

9 功能说明 

设置暴力破解的系统参数。 
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功能说明(以选中为例) 
Priority：线程优先级 

Threads：并发的线程数 

Word／Thread: 每个线程读入的单词数 

Auto Adjust Thread：根据网络情况，自动调整线程数。线程数会自动加 1，直到出

现阻塞为止。 

Port：设定各个服务的 TCP端口。 

6.5.3 Dictionary Option 

9 快捷键 

N/A 

9 功能说明 

设置暴力破解时字典/方案。 
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功能说明(以选中为例) 
Convert to Lower Case：将单词转换为小写 

Convert to Upper Case：将单词转换为大写 

Upper Case First: 将单词的第一个字母变为大写 

Add Suffix：为每一个单词加上后缀，后缀来源于指定的后缀文件(*.suf)。 

6.5.4 Scanning Option 

9 快捷键 

N/A 

9 功能说明 

设置暴力破解的其他选项。 
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功能说明(以选中为例) 
Enable Interrupt：允许在扫描过程中中断 

Popup Windows When Crack：当破解成功时弹出提示窗口 

FTP Verify: 使用 FTP校验用户是否被允许 

Auto Refresh：显示界面自动刷新 

Bind Host to IP: 将域名转换为 IP形式 

Use HTTP1.1 Protocal: 使用 HTTP1.1协议 

Disconnect When Each Thread Done: 每一个线程结束的时候都中断连接 

Auto Log File：自动记录扫描日志 

Log File：选择日志记录文件 

Scan Active Thread Every * ms：每间隔 100ms启动一个新的线程 

Thread TimeOut: 线程超时 

6.5.5 Single Mode Option 

9 快捷键 
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N/A 

9 功能说明 

设置简单模式暴力破解的字典选项。 

 

 

功能说明(以选中为例) 
Add Suffix to Username：从指定的后缀文件中加入后缀在用户名后 

Double Username：双写用户名，例如 john->johnjohn 

Reverse Username: 反转用户名，例如 john->nhoj 

Suffix File：后缀文件 

Use Single.INI: 在简单模式中使用字典 Single.INI 

6.5.6 Ememurate IPC Option 

9 快捷键 

N/A 

9 功能说明 

对 IPC进行枚举用户信息的选项。 
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功能说明(以选中为例) 
Emenurate All Users：从指定的后缀文件中加入后缀在用户名后 

Limited * Users：最多枚举指定的用户数目 

Add User From File If Emenurate Has Failed: 如果枚举失败，从指定的用户

列表中加入用户名。一般情况下不建议使用此项，因为会有大量的 Win9x/ME系统会被加

入用户名，实际上这是没有任何意义的。 

6.5.7 TCP Network Option 

9 快捷键 

N/A 

9 设置 

设置 TCP连接的 Socket超时 

 

 

功能说明(以选中为例) 
Connect TimeOut：连接超时(毫秒) 

Data TimeOut：发送和接收时超时设置(毫秒) 
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6.5.8 Other 

9 快捷键 

N/A 

9 功能说明 

设置和显示效果有关的选项。 

 
 

功能说明(以选中为例) 
Animate Window：窗口出现的速度 

Notication Mail Content：发送 Mail 给管理员的内容，当密码被破解之后可以发

送一个 Mail给这个用户。 

6.5.9 Language (Disable) 

流光的语言版本会根据所使用系统的不同自动变换，不用手工指定。 

6.5.10 Reset Default Options 

9 快捷键 

N/A 
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9 功能说明 

恢复默认的设置。当流光出现使用不正常的情况，可以用这个功能恢复默认

的选项。 

需要流光重新启动才会生效。 

6.6 工具 

6.6.1 Dictionary Tool (SubMenu) 

6.6.1.1 Ultra Dictionary III - Fluxay Edition 

9 快捷键 

Ctrl+H 

9 功能说明 

启动字典生成工具。 

6.6.1.2 Chinese PinYin Regula 

9 快捷键 

N/A 

9 功能说明 

根据中文拼音规则产生字典。 
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功能说明(以选中为例) 
Phrase：组成单词的字母短语 

Limit 8 Charaters： 产生的单词最多不超过 8位，否则将被舍弃。 

File：保存的字典文件名称 

?: 产生的字典是否被分割 

6.6.1.3 English Regula 

9 快捷键 

N/A 

9 功能说明 

根据英文单词规则产生字典。 
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功能说明(以选中为例) 
Phrase：组成单词的字母短语 

Limit 8 Charaters：产生的单词最多不超过 8位，否则将被舍弃。 

Single1：单辅音 

Single2：单元音 

File：保存的字典文件名称 

?: 产生的字典是否被分割 

6.6.1.4 Combine Dictionary 

9 快捷键 

N/A 

9 功能说明 

将两个字典的每一个单词进行拼接组合。 
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功能说明(以选中为例) 
Source File 1：第一个字典文件 

Source File 2：第二个字典文件 

Dest File: 目标文件名称 

Limit 8 Charaters：产生的目标文件中每一个单词最多不超过 8位，否则将被舍弃。

 

注意这个功能不是简单地文件追加，而是对两个文件中每一个单词进行组合

拼接。 

6.6.1.5 Spilit Dictionary 

9 快捷键 

N/A 

9 功能说明 

字典分割工具。 
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功能说明(以选中为例) 
Source File ：需要分割的字典文件 

Spilit into * Parts：分割为指定的部分(2-10)，文件名分别为源文件名加 0-9。

Delete Source File: 分割完成后，删除原先的文件。 

Limit 8 Charaters：产生的目标文件中每一个单词最多不超过 8位，否则将被舍弃。

 

注意：源文件必须大于 120K，否则将不能分割。 

6.6.1.6 Edit Schedule File 

9 快捷键 

N/A 

9 功能说明 

方案文件编辑工具。 

 

 

功能说明(以选中为例) 
1-8 ：分别代表每一个单词的 1-8位字母组合范围 

Save As：指定保存的方案文件 

Open File: 打开已有的方案文件进行编辑 
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6.6.1.7 Filter 

9 快捷键 

N/A 

9 功能说明 

对现有字典进行过滤。 

 
 

功能说明(以选中为例) 
Source ：需要过滤的源文件 

Dest：保存的目标文件 

Convert to Lower Case: 转换为小写字母 

Exclude Symbol：过滤掉包含有符号的单词 

Exclude Num：过滤掉包含有数字的单词 

Sort：指定新的文件中单词的排列顺序 

 

6.6.2 NT/IIS Tools (SubMenu) 

6.6.2.1 NT Pipe Remote Shell 

9 快捷键 

N/A 

9 功能说明 
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通过 WindowsNT/Windows 2000管道提供远程执行命令。 

 

 

功能说明(以选中为例) 
NT IPC IP ：远程 NT/2000主机 IP 

User：用户帐号，必须属于超级用户组 

Password：密码 

点击［Connect］，连接成功后即可执行命令。 

 

 

6.6.2.2 IIS Remote Shell 

9 快捷键 

N/A 

9 功能说明 

通过 IIS的漏洞执行命令。 
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功能说明(以选中为例) 
IIS Server ：远程运行 IIS主机 IP 

Type：UNICODE漏洞的种类，具体情况依据于扫描的结果。 

Allow IIS Detect CMD：允许 IIS检测 CMD，当执行命令出现问题的时候可以尝试选

择此项。 

6.6.2.3 IPC Planter 

9 快捷键 

Ctrl+P 

9 功能说明 

利用 NT/2000的定时服务来启动指定的程序。 

 

 

功能说明(以选中为例) 
Host IP ：远程主机 IP 
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User：用户帐号，必须属于超级用户组。 

Password：密码 

Local File：需要执行的程序在本地的存放位置 

Remote File：复制到远程主机的位置 

Command：命令执行时的命令行参数，此项可以为空。 

 

当成功执行后，程序最多在 60秒后就会开始运行。 

6.6.2.4 Download NT SAM 

9 快捷键 

N/A 

9 功能说明 

利用漏洞下载 NT/2000的密码文件 SAM到本地，这个功能需要选中漏洞列

表中相应的主机。 

6.6.2.5 Upload NT SAM 

9 快捷键 

N/A 

9 功能说明 

利用漏洞将 NT/2000的密码文件 SAM上传到指定的 FTP服务器。当上传

成功后，可以通过此 FTP服务器下载到本地。 

这个功能需要选中漏洞列表中相应的主机。 

6.6.3 MSSQL Tools (SubMenu) 

6.6.3.1 Remote Shell 

9 快捷键 

Ctrl+Q 

9 功能说明 
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通过 MSSQL系统在远程系统中执行命令。 

这个工具有两个版本： 

版本 1：[Setup_Dir]\SqlRCmd\SqlRCmd_Express （适用于本机已

经安装了 SQLServer） 

版本 2：[Setup_Dir]\SqlRCmd\SqlRCmd_Normal （适用于本机没有

安装 SQLServer）。 

 

 

功能说明(以选中为例) 
Server ：远程 MSSQL的主机 IP 

User：MSSQL的系统用户帐号，必须属于 SA组。 

Password：密码 

SQL Server Installed：本机已经安装了 SQL Server。选择此项的目的在于流光可

以自动选择使用哪一个版本的 SQL远程连接工具。 

Console Mode：使用控制台模式 

 

6.6.4 Define Mode File (SubMenu) 

6.6.4.1 Scanning Single Mode File 

9 快捷键 

N/A 

9 功能说明 
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编辑暴力破解模式下简单模式的默认字典文件。 

6.6.4.2 IPC$ Single Mode File 

9 快捷键 

N/A 

9 功能说明 

编辑破解 IPC主机在获得用户名时，使用的默认字典文件。 

6.6.4.3 IPC$ Force mode File 

9 快捷键 

N/A 

9 功能说明 

编辑破解 IPC主机在没有获得用户名时，使用的默认字典文件。 

6.6.5 Fluxay Sensor Tools (SubMenu) 

6.6.5.1 Install Fluxay Sensor 

9 快捷键 

Ctrl+I 

9 功能说明 

安装扫描探测引擎，详情参见安装本地扫描引擎。 

6.6.5.2 Update Fluxay Sensor 

9 快捷键 

N/A 

9 功能说明 

升级扫描引擎。 
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功能说明(以选中为例) 
Sensor IP ：需要升级扫描引擎的主机 IP 

UserName：扫描引擎的控制用户名(不是系统的用户名) 

Password：控制用户的密码 

Control Port：扫描引擎的控制端口 

Update File：升级的新文件 

6.6.5.3 Remove Fluxay Sensor 

9 快捷键 

N/A 

9 功能说明 

删除已经安装的扫描引擎。 

 
 

功能说明(以选中为例) 
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Host IP ：需要删除扫描引擎的主机 IP 

NT Account：系统用户 

Password：用户密码 

Service Name：服务名称 

 

这个功能不仅可以删除扫描引擎，还可以用来删除其他服务。 

6.6.5.4 Manager Fluxay Sensor 

9 快捷键 

Ctrl+M 

9 功能说明 

管理扫描引擎，详细请见管理扫描引擎一节。 

6.6.6 Remote Sniffer (SubMenu) 

6.6.6.1 Install ARP Network Sniffer 

9 快捷键 

Alt+I 

9 功能说明 

安装嗅探引擎，详细请见安装本地嗅探引擎（需要网络适配器）一节。 

6.6.6.2 Remote ARP Network Sniffer 

9 快捷键 

Alt+S 

9 功能说明 

启动网络嗅探工具，详细请见网络嗅探一节。 

6.6.6.3 Manager ARP Network Sniffer 

9 快捷键 

N/A 
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9 功能说明 

管理已经安装的嗅探引擎，详细请见管理嗅探引擎一节。 

6.6.7 Misc Tools (SubMenu) 

6.6.7.1 PCAnyWhere Password Decipher 

9 快捷键 

Ctrl+T 

9 功能说明 

PCAnyWhere 密码还原工具，详细情况请见 PCAnyWhere密码还原一节。 

6.6.7.2 Get Username Form UNIX Passwd File 

9 快捷键 

N/A 

9 功能说明 

从 UNIX密码文件中提取用户名，详细请见从 UNIX密码文件提取用户名一

节。 

6.6.7.3 Mail to Victim User 

9 快捷键 

N/A 

9 功能说明 

发送邮件给被破解了密码的用户。 

6.6.7.4 Set Encyption Key 

9 快捷键 

N/A 

9 功能说明 

修改和嗅探引擎通信时加密的密钥，详细情况见设置密钥一节。 

如果密钥修改，那么以前的扫描中间文件将不能正常解码，但是不影响建立新的扫
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描任务。 

6.7 帮助 

6.7.1 Fluxay 5 User’s Manual 

9 快捷键 

F1 

9 功能说明 

查阅本说明。 

6.7.2 Old User’s Manual (SubMenu) 

9 快捷键 

N/A 

9 功能说明 

以前各个版本的功能说明，可以作为本参考的补充。 

6.8 关于 

6.8.1 About netxeyes 

9 快捷键 

N/A 

9 功能说明 

关于 netXeyes 

6.8.2 About Fluxay 

9 快捷键 

N/A 
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9 功能说明 

流光 5的版权说明。 

6.8.3 Fluxay Forum 

9 快捷键 

Ctrl＋F 

9 功能说明 

连接到流光论坛，有关流光的问题讨论。 

6.8.4 WebSite 

9 快捷键 

N/A 

9 功能说明 

连接到 netXeyes的 WEB站点。 

6.8.5 Check Update 

9 快捷键 

N/A 

9 功能说明 

检查流光有无最新的版本可以升级。 

6.8.6 System BroadCast 

9 快捷键 

N/A 

9 功能说明 

系统广播，可以从这个地方获得有关软件最新消息。 
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7 文件列表 

7.1 [ROOT_Directory] 

7.1.1 2.suf 

两位数字组合前缀字典。 

7.1.2 2a.dic 

两位字母组合字典。 

7.1.3 3a.dic 

三位字母组合字典。 

7.1.4 3n.dic 

三位数字组合字典。 

7.1.5 3n.suf 

三位数字组合前缀字典。 

7.1.6 4n.dic 

四位数字组合字典。 

7.1.7 brute.dic 

扫描引擎使用的默认暴力破解密码字典。 
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7.1.8 brute.ult 

扫描引擎使用的默认暴力破解用户名列表。 

7.1.9 chinese.dic 

针对国内用户常用的密码字典。 

7.1.10 Cracked.pwd 

已经破解的用户帐号记录。 

7.1.11 exploit_cn.rule 

针对中文版产生的报告格式化的文件。 

7.1.12 exploit_en.rule 

针对英文版产生的报告格式化的文件。 

7.1.13 Flux.Log 

流光暴力破解的扫描记录文件。 

7.1.14 Fluxay5Beta2.exe 

流光 5程序主文件。 

7.1.15 IpcDetail.Inf 

在 IPC扫描时，扫描的记录文件。 
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7.1.16 IpcList.INI 

在 IPC枚举失败的时候，强制加入的用户名列表。 

7.1.17 ipcsingle.ini 

探测 IPC用户密码时，默认使用的密码字典。 

7.1.18 Last.Flx 

流光退出时，自动保存的文件。 

7.1.19 Last.HIF 

流光退出时自动保存的文件。 

7.1.20 Last.pwd 

最后一次暴力破解的记录文件。 

7.1.21 libmySQL.dll 

MySQL动态链接库。 

7.1.22 MFC42.DLL 

系统动态库。 

7.1.23 MSVCP60.DLL 

系统动态库。 
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7.1.24 Name.dic 

由常见姓氏组成的字典。 

7.1.25 netxeyeslogo.jpg 

流光的图标文件。 

7.1.26 Normal.dic 

常用的字典文件。 

7.1.27 normal.suf 

常用的前缀字典文件。 

7.1.28 ntcgi.dat 

基于 IIS的 CGI漏洞规则库，这个规则库可以根据需要增加内容。 

7.1.29 NTCmd.exe 

利用管道在远程 NT系统中执行命令的工具，详情请见 NTCMD一节。 

7.1.30 NTLMAuth.dll 

提供 NTLM挑战应答方式的动态库。 

7.1.31 password.Dic 

常见的组合构成的密码字典。 
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7.1.32 PipeCmd.exe 

供 NTCMD使用的管道服务端程序。 

7.1.33 Private.Key 

记录和扫描引擎通信的密钥文件。 

7.1.34 protocol.ini 

嗅探引擎的协议设置文件，可以根据需要增加新的协议。 

格式： 

协议名:类型:端口号 

例如：SSH:TCP:22 

7.1.35 PubAuth.Key 

流光自身验证的密钥。 

7.1.36 py.dic 

由拼音规则组成的字典。 

7.1.37 RHV.dll 

用于 Linux RPC的动态库。 

7.1.38 search.his 

查找功能的历史记录。 
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7.1.39 ShowWeb.INI 

WEB更新记录文件。 

7.1.40 single.dic 

用于暴力模式下简单模式的密码字典文件。 

7.1.41 Single.INI 

用于暴力模式下简单模式的密码字典设置文件，Single.DIC 就是根据这

个文件产生的。 

7.1.42 sqlrcmd.exe 

提供 MSSQL远程连接的工具，详细请见 SQLRCMD一节。 

7.1.43 System.Conf 

系统设置记录文件。 

7.1.44 Sys_Month_Date.Dic 

366天，月日组成的字典文件。 

7.1.45 Sys_Year.Dic 

从 1950-1999年份字典文件。 

7.1.46 uninstal.exe 

反安装文件。 
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7.1.47 uninstal.ini 

反安装记录文件。 

7.1.48 unixcgi.dat 

基于 UNIX WEB的 CGI漏洞规则库，可以根据需要自行增加。 

7.1.49 Words.dic 

大多数英文单词组成的字典。 

7.2 Exploit 

7.2.1 7350wu-v5.tar.gz 

wuftpd远程溢出程序（Linux）。 

7.2.2 ADMmounted.tgz 

攻击程序（Linux）。 

7.2.3 amd.c 

攻击程序（Linux）。 

7.2.4 linx86_bind.c 

Bind远程溢出攻击程序。 
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7.2.5 lsub.c 

IMAP4rev1 v12.261, v12.264 and 2000.284远程溢出攻击工具。 

7.2.6 oracle.exe 

Oracle 8i For Windows 2000远程溢出攻击工具。 

7.2.7 rpc.autofsd.c 

RPC.autofsd远程溢出攻击工具。 

7.2.8 rpcexpOK.exe 

Windows RPC Locator远程溢出攻击工具。 

7.2.9 rpc_cmsd.c 

RPC.cmsd远程溢出攻击工具。 

7.2.10 sadmindex-sparc.c 

sadmindex远程溢出攻击工具（For Sparc） 

7.2.11 seclpd.c 

RedHat 7.0 LPD 远程溢出攻击工具。 

7.2.12 snmpxdmid.c 

RPC.snmpxdmind远程溢出攻击工具（For Sparc）。 
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7.2.13 sql2.exe 

SQL 2000远程远程溢出攻击程序。 

7.2.14 statdx.c 

Redhat 6.2 RPC.statd远程溢出攻击工具。 

7.2.15 ttdbserver.c 

RPC.ttdbserver远程溢出攻击工具（For Sparc） 

7.2.16 webdavx3.exe 

IIS 5.0 WEBDAV远程溢出攻击工具。 

7.2.17 wu-ftp.tgz 

wu-ftpd远程溢出攻击工具。 

7.2.18 wuftp25.tar.gz 

wu-ftpd 2.5远程溢出攻击工具。 

7.2.19 local (Sub_Directory) 

7.2.19.1 su.c 

Linux 本地溢出程序。 
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7.2.19.2 Sun Sparc (Sub Directory) 

这个目录中含有已经编译成功，从 SunOS 5.6-5.8（Sparc）的多个本地

溢出程序。包括： 

\5.6\lpset 

\5.6\lpstat 

\5.6\netpr 

\5.7\lpset 

\5.7\lpstat 

\5.7\netpr 

\5.7\xsun 

\5.8\kcssun 

7.2.20 wu-ftd (Sub_Directory) 

wu-ftpd的远程溢出攻击程序。包括： 

forcer 

woot-exploit 

7.3 FluxaySensor 

7.3.1 Anything.INI 

在产生一个新的扫描任务时，随机产生的配置文件。 

7.3.2 brute.dic 

扫描引擎默认使用的暴力破解密码字典。 

7.3.3 brute.ult 

扫描引擎默认使用的暴力破解用户名字典。 
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7.3.4 ControlService.exe 

控制服务主程序。 

7.3.5 FluxaySensor.exe 

扫描引擎主程序。 

7.3.6 libmySQL.dll 

MySQL动态链接库。 

7.3.7 Name.dic 

常用的姓名组成的字典。 

7.3.8 Normal.dic 

常用的单词、IT专业术语组成的字典。 

7.3.9 NTLMAuth.dll 

NTLM应答方式动态链接库。 

7.3.10 password.Dic 

常用的密码组成的密码字典。 

7.3.11 pskill.exe 

强制结束进程的工具。 
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7.3.12 RHV.dll 

用于 Linux RPC的动态库。 

7.3.13 single.dic 

用于暴力模式下简单模式的密码字典文件。 

7.3.14 Sys_Month_Date.Dic 

366天，月日组成的字典文件。 

7.3.15 Sys_Year.Dic 

从 1950-1999年份字典文件。 

7.3.16 Words.dic 

大多数英文单词组成的字典。 

7.3.17 Plugins (Sub_Directory) 

7.3.17.1 fpe2k.flux 

FrontPage 扩展远程溢出插件。 

7.3.17.2 iiswebdav.flux 

IIS WEBDAV远程溢出插件。 

7.3.17.3 nullprinter.flux 

NULL.Print 远程溢出插件。 
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7.3.17.4 qpop.flux 

qpop远程溢出插件。 

7.3.17.5 sunftpcwd.flux 

SunOS FTPD CWD验证用户名漏洞插件。  

7.3.17.6 w2krpc.flux 

Windows RPC Locator远程溢出插件。 

7.3.18 Reports (Sub_Directory) 

存储扫描产生的中间文件和报告。 

7.4 Help 

7.4.1 faq.mht 

使用 FAQ。 

7.4.2 fluxay4.html 

流光 4的使用说明 

7.4.3 Fluxay46.mht 

流光 4.6的使用说明。 

7.4.4 form.mht 

关于 Form探测的说明。 
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7.4.5 http.mht 

关于 HTTP暴力破解的说明。 

7.4.6 index.html 

流光 2.5的帮助文件。 

7.4.7 ipc.mht 

关于 IPC破解的说明。 

7.4.8 plugin.html 

关于插件的使用说明。 

7.4.9 remote.mht 

关于 IPC破解说明的第二部分。 

7.4.10 result.html 

流光 4扫描结果的分析说明。 

7.4.11 sql.mht 

关于 SQL扫描破解的说明。 

7.4.12 1.27 (Sub_Directory) 

包含有流光 1.27的说明文件。 
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7.4.13 image (Sub_Directory) 

存放帮助说明的相关图片文件。 

7.5 ocx 

7.5.1 HexEdit.ocx 

嗅探引擎使用的 OCX插件。 

7.5.2 register.bat 

注册插件的脚本。 

7.5.3 unregister.bat 

反注册插件的脚本。 

7.6 Plugins 

7.6.1.1 fpe2k.flux 

FrontPage 扩展远程溢出插件。 

7.6.1.2 iiswebdav.flux 

IIS WEBDAV远程溢出插件。 

7.6.1.3 nullprinter.flux 

NULL.Print 远程溢出插件。 

7.6.1.4 qpop.flux 

qpop远程溢出插件。 
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7.6.1.5 sunftpcwd.flux 

SunOS FTPD CWD验证用户名漏洞插件。  

7.6.1.6 w2krpc.flux 

Windows RPC Locator远程溢出插件。 

7.7 Reports 

7.7.1 IPFrom-IPEnd.html 

扫描报告，格式为起始 IP-结束 IP.html。 

7.7.2 IPFrom-IPEnd.PTR 

加密的扫描报告中间文件，格式为起始 IP-结束 IP.PTR。 

7.7.3 netxeyeslogo.jpg 

流光的图标。 

7.8 SetupNetCore 

7.8.1 Sys (Sub_Directory) 

7.8.1.1 NetCore.exe 

嗅探程序主文件。 

7.8.1.2 npf.sys 

嗅探核心驱动文件。 

7.8.1.3 packet.dll 

嗅探核心驱动动态链接库。 



 
流光 5用户手册                    

流光 5用户手册  第 157 页 共 158页 

7.8.1.4 pthreadVC.dll 

嗅探核心驱动动态链接库。 

7.8.1.5 wpcap.dll 

嗅探核心驱动动态链接库。 

7.9 SqlRcmd 

7.9.1 SqlRCmd_Express (Sub_Directory) 

已经安装了 SQL Server时，使用的 SQL连接工具。 

7.9.2 SqlRCmd_Normal (Sub_Directory) 

没有安装 SQL Server时，使用的 SQL连接工具。 

7.10 Tools 

7.10.1 IIS5Hack.exe 

NULL.PRINT远程溢出攻击工具。 

7.10.2 NETSVC.EXE 

远程启动 NT服务的工具。 

7.10.3 NTLM.EXE 

修改 Windows 2000 Telnet 默认登陆验证方式的程序。 
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7.10.4 PSKILL.EXE 

NT/2000中强制结束进程的工具。 

7.10.5 RunAsEx.exe 

非交互式的 RunAs工具，即可以用其他用户的身份启动程序。 

7.10.6 sql2.exe 

MSSQL 2000 UDP 1434远程溢出程序。 

7.10.7 SRV.EXE 

监听 TCP端口 99，提供 NT/2000的 CMD SHELL。 

 


